Upgrade immediately to Joomla! 1.0.11

Created on Monday, 28 August 2006 12:00

 

To help ensure your site is running at the minimum level of acceptable security, two new visible warning have been added to the Admin Backend area.

* It is important to note that these two new features to the 1.0.x series do not garuantee that your site is 100% fully secure. Only that you are operating at the minimum level of security.* 

Security Warning

A new security warning will appear in the backend main page if your system is NOT running under the following recommended state:

  • PHP magic_quotes_gpc setting is `ON`
  • PHP register_globals setting is `OFF`
  • Joomla! RG_EMULATION setting is `OFF`

The warning message will appear in Backend Admin area `homepage`, `Global Configuration page` and the `System Information page`

Image
Image

Joomla! Version Warning 

After your version of Joomla! is more than 30 days old a warning will appear in you Backend Admin area `homepage`, indicating the age of the version you are using and link to where you can check for information about the latest version of Joomla!.
Image 

Further in the `Global Configuration page` and the `System Information page` this warning will always be visible.

Image

This warning is intended as a visible reminder to ensure you are using the newest/latest version of Joomla! at all times. 

We strongly encourage you (if not already done so) to register yourself on forum.joomla.org and to subscribe on the announcements thread to get notified by important security releases (you need to be a registered member of the forums to recieve notifications). We also encourage you to do same for all third-party extensions you use, where available.