Technical Requirements

Technical Requirements

Requirements for Supported Software

Requirements for Joomla! 3.x

SoftwareRecommendedMinimumMore information
PHP (Magic Quotes GPC off)[1] 5.4 + 5.3.10 + http://www.php.net
Supported Databases:
MySQL (InnoDB support required) 5.1 + 5.1 + http://www.mysql.com
SQL Server 10.50.1600.1+ 10.50.1600.1+ http://www.microsoft.com/sql
PostgreSQL 8.3.18 + 8.3.18 + http://www.postgresql.org/
Supported Web Servers:
Apache[2]
(with mod_mysql, mod_xml, and mod_zlib)
2.x + 2.x + http://www.apache.org
Nginx 1.1 1.0 http://wiki.nginx.org/
Microsoft IIS[5] 7 7 http://www.iis.net

 

Requirements for Unsupported Software

Requirements for Joomla! 1.6, 1.7, & 2.5 - Support ends on December 31, 2014

SoftwareRecommendedMinimumMore information
PHP 5.4 + 5.2.4 + http://www.php.net
Supported Databases:
MySQL 5.0.4 + 5.0.4 + http://www.mysql.com
SQL Server[4] 10.50.1600.1+ 10.50.1600.1+ http://www.microsoft.com/sql
Supported Web Servers:
Apache[2]
(with mod_mysql, mod_xml, and mod_zlib)
2.x + 2.x + http://www.apache.org
Nginx 1.1 1.0 http://wiki.nginx.org/
Microsoft IIS[5] 7 7 http://www.iis.net

 

Requirements for Joomla! 1.5 - Support ended on December 31, 2012

SoftwareRecommendedMinimumMore information
PHP[3] 5.2 4.3.10 + http://www.php.net
Supported Databases:
MySQL 4.1.x + 3.23 http://www.mysql.com
Supported Web Servers:
Apache[2]
(with mod_mysql, mod_xml, and mod_zlib)
2.x + 1.3 http://www.apache.org
Microsoft IIS[5] 7 6 http://www.iis.net

 

Requirements for Joomla! 1.0 - Support ended on July 22, 2009

SoftwareRecommendedMinimumMore information
PHP[3] 5.2 or 5.3 4.2 http://www.php.net
Supported Databases:
MySQL 4.1.x + 3.23 http://www.mysql.com
Supported Web Servers:
Apache[2]
(with mod_mysql, mod_xml, and mod_zlib)
2.x + 1.3 http://www.apache.org
Microsoft IIS[5] 7 6 http://www.iis.net

 

Footnotes

[1] PHP 5.3.1 is required for versions 3.0 through 3.2. At 3.3, the minimum is raised to PHP 5.3.10.

[2] In order to use SEO URLs, you will need to have the Apache mod_rewrite extension installed.

[3] Do not use PHP 4.3.9, 4.4.2 or 5.0.4. These releases have known bugs that will interfere with installation. Zend Optimizer 2.5.10 for PHP 4.4 also has serious bugs and you should ask your host to upgrade to a newer version. Joomla! versions 1.5.15 and later are compatible with PHP 5.3. Note that the OpenID library is not compatible with PHP 5.3.

[4] Support for Microsoft SQL Server was added for the 2.5 release; 1.6 and 1.7 do not have this support.

[5] For Microsoft IIS (depending on your setup) you may need the following:

For further assistance using Microsoft IIS, visit the Joomla! IIS forum.

 

Configuration Options

If installing on a local computer, there are a number of packages that will help you get set up quicker than individual installations:

If you need other options, we recommend visiting our installation forums for more information.